Results 1 to 3 of 3

Thread: Problems Printing With EPSON TM-U220PD (on a USB adapter)

  1. #1

    Problems Printing With EPSON TM-U220PD (on a USB adapter)

    Hello everyone,
    I'm new to Floreant POS but I've been programming for a while. I have the following setup:
    - Floreant 14705
    - Windows 8.1
    - EPSON TM-U220PD connected through a Manhattan USP-to-Parallel Cable
    I have tried several different drivers: EPSON TM-U220 Receipt, EPSON LX-300+/ii, Generic / Text Only. The driver that works best is the Generic / Text Only. All the others do not print well. But Floreant POS only prints when I use the LX-300 driver, but it doesn't print legible enough, just like when I try to print with other programs. When I use the Generic/Text Only driver, all other programs print well, but with Floreant I do not get anything. I also tried updating the kitchen jasper template following a very useful youtube video, but it didn't fix the problem. The command prompt doesn't show any messages, and the program continues execution as normal, just no print out.

    I would really appreciate some help with this. Has anyone run into this scenario? I think what is complicating the issue is the fact that I'm using a parallel printer through a USB. I haven't tried installing it on a desktop with a parallel port to see if it works. I've worked on this for several days now and no luck. Please help. Thank you.

  2. #2
    We have not used Parallel-USB printer connection of TM220. But they should not be different. in most of the cases Epson Advanced Printer driver is what you need.Remove all of the driver and try to install that APD driver again. Generic & Text driver will not work. or driver that was not designed for that model. First get sure is if driver is installed and you can print sometime. .Then fine tune layout with Jasper iReport editor. Get sure if JDK 7 and Jasper ireport 4.0.1.

  3. #3
    I know is an old post but I was try using this printer with the same cable, the results are that you have to use generic driver other drivers wont work with Windows. The Generic Driver wont work with Floreant.
    Maybe changing the cable to parallel and adding a parallel port to computer will work. But parallel to usb wont work

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts